Differences

This shows you the differences between two versions of the page.

Link to this comparison view

hypervisor:deploy1404 [2015/09/10 15:19]
giancarlo created
hypervisor:deploy1404 [2015/09/10 15:34] (current)
giancarlo
Line 14: Line 14:
 </code> </code>
 </WRAP> </WRAP>
-  * Upgrade packages to last version and add myuser to libvirtd group+  * Upgrade packages to last version
 <WRAP prewrap center> <WRAP prewrap center>
 <code> <code>
 # apt-get update # apt-get update
 # apt-get upgrade # apt-get upgrade
-# adduser myuser libvirtd 
-# reboot 
 </code> </code>
 </WRAP> </WRAP>
   * Verify KVM is up   * Verify KVM is up
 <WRAP prewrap center> <WRAP prewrap center>
-<code>+<code>virsh -c qemu:///system list
 $ virsh -c qemu:///system list $ virsh -c qemu:///system list
  Id Name                 State  Id Name                 State
Line 31: Line 29:
  
 </code> </code>
-</WRAP> 
-  * Install **Open vSwitch** 
-<WRAP prewrap center> 
-<code> 
-# aptitude purge ebtables 
-# virsh net-destroy default 
-# virsh net-autostart --disable default 
-# service libvirt-bin stop 
-# service qemu-kvm stop 
-</code> 
-</WRAP> 
-NOTE: If install Ubuntu from 12.04.3 LTS server (linux 3.8) you need to manually install "apt-get install openvswitch-datapath-lts-raring-dkms" before next step. 
-<WRAP prewrap center> 
-<code> 
-# aptitude install openvswitch-switch openvswitch-controller openvswitch-brcompat 
-# nano -w /etc/default/openvswitch-switch 
-     BRCOMPAT=yes 
-# service openvswitch-switch restart 
-# service openvswitch-controller restart 
-# reboot 
-</code> 
-</WRAP> 
-  * Verify modules and service: 
-<WRAP prewrap center> 
-<code> 
-$ lsmod | grep br 
-     brcompat_mod           13512  
-     openvswitch_mod        83993  2 brcompat_mod 
- 
-$ service openvswitch-switch status 
-     ovsdb-server is running with pid 1349 
-     ovs-vswitchd is running with pid 1358 
-     ovs-brcompatd is running with pid 1393 
-</code> 
-</WRAP> 
-  * Configure Open vSwitch 
-Add bridge "br0" (libvirt compatibility) and connect to eth0 (untagged + VLANs tagged) 
-<WRAP prewrap center> 
-<code> 
-# ovs-vsctl add-br br0 
-# ovs-vsctl add-port br0 eth0 
-</code> 
-</WRAP> 
-Add virtual bridges br2 (VLAN tag 2) and br3 (VLAN tag 3) 
-<WRAP prewrap center> 
-<code> 
-# ovs-vsctl add-br br2 br0 2 
-# ovs-vsctl add-br br3 br0 3 
-</code> 
-</WRAP> 
-Add dummy entries in /etc/network/interfaces then reboot 
-<WRAP prewrap center> 
-<code> 
-# nano -w /etc/network/interfaces 
- 
-auto eth0 
-iface eth0 inet manual 
-up ifconfig $IFACE 0.0.0.0 up 
-down ifconfig $IFACE down 
- 
-auto br0 
-iface br0 inet manual 
-up ifconfig $IFACE 0.0.0.0 up 
-down ifconfig $IFACE down 
- 
-auto br2 
-iface br2 inet manual 
-up ifconfig $IFACE 0.0.0.0 up 
-down ifconfig $IFACE down 
- 
-auto br3 
-iface br3 inet manual 
-up ifconfig $IFACE 0.0.0.0 up 
-down ifconfig $IFACE down 
-</code> 
-</WRAP> 
-Edit libvirt upstart script to wait for bridge: 
-<WRAP prewrap center> 
-<code> 
-# nano -w /etc/init/libvirt-bin.conf 
- 
-     - start on runlevel [2345] 
-     + start on (runlevel [2345] and net-device-up IFACE=br0) 
- 
-# reboot 
-</code> 
-</WRAP> 
-Verify configuration 
-<WRAP prewrap center> 
-<code> 
-# ovs-vsctl show 
- 
-    Bridge "br0" 
-        Port "eth0" 
-            Interface "eth0" 
-        Port "br3" 
-            tag: 3 
-            Interface "br3" 
-                type: internal 
-        Port "br2" 
-            tag: 2 
-            Interface "br2" 
-                type: internal 
-        Port "br0" 
-            Interface "br0" 
-                type: internal 
-    ovs_version: "1.4.0+build0" 
-</code> 
-</WRAP> 
-  * Install and configure **iSCSI** initiator 
-<WRAP prewrap center> 
-<code> 
-# apt-get install open-iscsi 
-# nano -w /etc/iscsi/iscsid.conf 
-     node.startup = automatic 
-# /etc/init.d/open-iscsi restart 
-</code> 
-</WRAP> 
-Discover targets 
-<WRAP prewrap center> 
-<code> 
-# iscsiadm -m discovery -t st -p iSCSIServerIP 
-</code> 
-</WRAP> 
-Remove unwanted nodes 
-<WRAP prewrap center> 
-<code> 
-# rm -R /etc/iscsi/nodes/iqnxxxx 
-</code> 
-</WRAP> 
-Configure auth for node 
-<WRAP prewrap center> 
-<code> 
-# nano -w /etc/iscsi/nodes/iqnyyyy/1234/default 
-     node.session.auth.authmethod = CHAP 
-     node.session.auth.username = user 
-     node.session.auth.password = password 
- 
-# /etc/init.d/open-iscsi restart 
- 
-</code> 
-</WRAP> 
- 
-  * HW monitor tools 
-<WRAP prewrap center> 
-<code> 
-# wget http://downloads.linux.hp.com/SDR/downloads/bootstrap.sh 
-# chmod +x bootstrap.sh 
-# ./bootstrap.sh -v -r stable ProLiantSupportPack 
-# gpg --keyserver pgpkeys.mit.edu --recv-key 527BC53A2689B887 && gpg --export --armor 527BC53A2689B887 | sudo apt-key add - 
-# apt-get update 
-# apt-get install hp-health 
- 
-# wget ftp://ftp.hp.com/pub/softlib2/software1/pubsw-linux/p1257348637/v71527/hpacucli-9.10-22.0.x86_64.rpm 
-# apt-get install alien 
-# alien --scripts -d hpacucli-9.10-22.0.x86_64.rpm 
-# dpkg -i hpacucli_9.10-23_amd64.deb 
-</code> 
-</WRAP> 
-  * HW monitor tools UPDATE 
-Change apt source from 
-<WRAP prewrap center> 
-<code> 
-deb http://downloads.linux.hp.com/SDR/downloads/ProLiantSupportPack stable/current non-free 
-</code> 
-</WRAP> 
-to 
-<WRAP prewrap center> 
-<code> 
-deb http://downloads.linux.hp.com/SDR/downloads/MCP/ubuntu precise current/non-free 
-</code> 
-</WRAP> 
-Then 
-<WRAP prewrap center> 
-<code> 
-# apt-get update 
- 
-# apt-get --only-upgrade install hp-health 
-# apt-get --only-upgrade install hpacucli 
-</code> 
-</WRAP> 
----- 
-<WRAP right 30% rightalign lo> 
-[[hypervisor:lvmstart|Main LVM configuration]] ⇒ 
-</WRAP> 
-<WRAP center 30% centeralign lo> 
-⇑ [[hypervisor:start|Hypervisor]] 
 </WRAP> </WRAP>
  
 
 
hypervisor/deploy1404.txt · Last modified: 2015/09/10 15:34 by giancarlo

Developers: CNR IRCrES IT Office and Library
Giancarlo Birello (giancarlo.birello _@_ ircres.cnr.it) and Anna Perin (anna.perin _@_ ircres.cnr.it)
DigiBess is licensed under: Creative Commons License
Recent changes RSS feed Creative Commons License Valid XHTML 1.0 Valid CSS Driven by DokuWiki
Drupal Garland Theme for Dokuwiki